複雑な mixin を書く機会があって、そろそろ Compass を使用してみなくてはと思って、ひとまずインストールして、いじってみようと思ったら、躓いたのでメモしときます。

下記のような結果になりました。

$ gem install sass
$ gem install compass
$ compass -v
-bash: compass: command not found

compassをインストールしたのにcommand not foundになる
`rbenv: rails: command not found`の対処方法

上記のページを参考にさせて頂いて、下記のようにしたらうまくいきましたm(_ _)mありがたや・・・。

$ gem install railties && rbenv rehash
$ compass -v
Compass 1.0.3 (Polaris)

できました!

rbenv は私の環境にもインストールしてあったので、これかなと思ったらそうでした。
ただ、この辺はとても疎くて説明を読んでもなかなか理解できませんでした。

そういえば、Sass についてそんなに勉強したことなかったので、評判の良いこの本でも買ってみようかなって思います。